Re: [PATCH v4 5/6] dir: expose cmp_name() and check_contains()
- From
Junio C Hamano <gitster@pobox.com>
- Date
- May 22, 2017, 00:38 UTC
- Message-ID
- <xmqq60gtraik.fsf@gitster.mtv.corp.google.com>
- In-Reply-To
- <20170518082154.28643-6-sxlijin@gmail.com>
Samuel Lijin <sxlijin@gmail.com> writes:
Show 13 quoted lines
> We want to use cmp_name() and check_contains() (which both compare > `struct dir_entry`s, the former in terms of the sort order, the latter > in terms of whether one lexically contains another) outside of dir.c, > so we have to (1) change their linkage and (2) rename them as > appropriate for the global namespace. The second is achieved by > renaming cmp_name() to cmp_dir_entry() and check_contains() to > check_dir_entry_contains(). > > Signed-off-by: Samuel Lijin <sxlijin@gmail.com> > --- > dir.c | 11 ++++++----- > dir.h | 3 +++ > 2 files changed, 9 insertions(+), 5 deletions(-)
Up to this point in the series all looked sensible. I haven't looked the last one carefully to form an opinion yet.
Thanks.