Re: [PATCH v3 0/3] replace test [-f|-d] with more verbose functions
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Feb 23, 2022, 22:59 UTC
- Message-ID
- <xmqq35k9qjeq.fsf@gitster.g>
- In-Reply-To
- <20220222215430.605254-1-cogoni.guillaume@gmail.com>
COGONI Guillaume <cogoni.guillaume@gmail.com> writes:
Show 6 quoted lines
> Make the code more readable in t/t3903-stash.sh and give more > friendly error message by replacing test [-f|-d] by the right > test_path_is_* functions. > Add new functions like test_path_is_* to cover more specifics > cases like symbolic link or file that we explicitly refuse > to be symbolic link.
All three look good to me.
Will queue.
As a possible #leftoverbits material, I suspect that we would eventually want to be able to say
test_path_is_file ! "$error_if_I_am_a_file" test_path_is_dir ! "$error_if_I_am_a_dir" test_path_is_symlink ! "$error_if_I_am_a_symlink"
so that we do not have to have the two ugly-looking special-case combination "test_path_is_X_not_symlink" but just express what we want with
test_path_is_file "$path" && test_path_is_symlink ! "$path"
Once that happens, the two helpers introduced with 2/3 of this series would become
test_path_is_file_not_symlink () {
test $# = 1 || BUG "1 param"
test_path_is_file "$1" &&
test_path_is_symlink ! "$1"
}But I do not want to see that as part of this series. Let's conclude this series and declare a success.
Thanks.