Re: [PATCH v3 00/10] teach replace objects to sha1_object_info_extended()
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Dec 12, 2013, 20:05 UTC
- Message-ID
- <xmqq1u1hu95x.fsf@gitster.dls.corp.google.com>
- In-Reply-To
- <20131211074147.11117.1155.chriscool@tuxfamily.org>
Christian Couder <chriscool@tuxfamily.org> writes:
> Here is version 3 of a patch series to improve the way > sha1_object_info_extended() behaves when it is passed a > replaced object. The idea is to add a flags argument to it > in the same way as what has been done to read_sha1_file().
Thanks.
Will take a look again (in the meantime, will queue on 'pu').
I do not think the new name for the bit is necessary nor it is a good change, though. Given an object name, reading the data and inspecting the metadata (i.e. type and size) should yield consistent results, so the original name is a perfectly appropriate name that means "use the replacement object when using read-sha1-file and friends to ask about an object". The use of the replacement object happens to be implmented via lookup-replace-object helper, but that is an implementation detail of _how_ it is done, not the high level descroption of _what_ the callers want to see done.
But that is just a minor nit.