[PATCH] path: for clarity, rename get_pathname to get_path_buffer
- From
Michal Nazarewicz <mina86@mina86.com>
- Date
- Jul 8, 2014, 13:15 UTC
- Message-ID
- <xa1t4mys56v6.fsf@mina86.com>
- In-Reply-To
- <xa1ta98k58qm.fsf@mina86.com>
The get_pathname function does not really return path name but rather a buffer to store pathname in. As such, current name is a bit confusing. Change the name as to make it clearer what the function is doing.
Signed-off-by: Michal Nazarewicz <mina86@mina86.com> --- path.c | 8 ++++---- 1 file changed, 4 insertions(+), 4 deletions(-)
This time sent with Junio's correct address.
diff --git a/path.c b/path.c index bc804a3..70e2f85 100644 --- a/path.c +++ b/path.c @@ -16,7 +16,7 @@ static int get_st_mode_bits(const char *path, int *mode) static char bad_path[] = "/bad-path/"; -static char *get_pathname(void) +static char *get_path_buffer(void) { static char pathname_array[4][PATH_MAX]; static int index; @@ -108,7 +108,7 @@ char *mkpath(const char *fmt, ...) { va_list args; unsigned len; - char *pathname = get_pathname(); + char *pathname = get_path_buffer(); va_start(args, fmt); len = vsnprintf(pathname, PATH_MAX, fmt, args); @@ -120,7 +120,7 @@ char *mkpath(const char *fmt, ...) char *git_path(const char *fmt, ...) { - char *pathname = get_pathname(); + char *pathname = get_path_buffer(); va_list args; char *ret; @@ -158,7 +158,7 @@ void home_config_paths(char **global, char **xdg, char *file) char *git_path_submodule(const char *path, const char *fmt, ...) { - char *pathname = get_pathname(); + char *pathname = get_path_buffer(); struct strbuf buf = STRBUF_INIT; const char *git_dir; va_list args;
-- 2.0.0.526.g5318336