threads / patch / 37076

patchpath: for clarity, rename get_pathname to get_path_buffer

Subject: [PATCH] path: for clarity, rename get_pathname to get_path_buffer

## tl;dr

2 messages between Jul 8, 2014 and Jul 8, 2014. Diffs are folded; open one to read it.

replies: 1people: 1as markdown or json

Michal Nazarewicz· Jul 8, 2014, 12:35 UTC · lore

The get_pathname function does not really return path name but rather a buffer to store pathname in. As such, current name is a bit confusing. Change the name as to make it clearer what the function is doing.

Signed-off-by: Michal Nazarewicz <mina86@mina86.com>
---
 path.c | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)
Show changes to path.c +4 −4
diff --git a/path.c b/path.c
index bc804a3..70e2f85 100644
--- a/path.c
+++ b/path.c
@@ -16,7 +16,7 @@ static int get_st_mode_bits(const char *path, int *mode)
 
 static char bad_path[] = "/bad-path/";
 
-static char *get_pathname(void)
+static char *get_path_buffer(void)
 {
 	static char pathname_array[4][PATH_MAX];
 	static int index;
@@ -108,7 +108,7 @@ char *mkpath(const char *fmt, ...)
 {
 	va_list args;
 	unsigned len;
-	char *pathname = get_pathname();
+	char *pathname = get_path_buffer();
 
 	va_start(args, fmt);
 	len = vsnprintf(pathname, PATH_MAX, fmt, args);
@@ -120,7 +120,7 @@ char *mkpath(const char *fmt, ...)
 
 char *git_path(const char *fmt, ...)
 {
-	char *pathname = get_pathname();
+	char *pathname = get_path_buffer();
 	va_list args;
 	char *ret;
 
@@ -158,7 +158,7 @@ void home_config_paths(char **global, char **xdg, char *file)
 
 char *git_path_submodule(const char *path, const char *fmt, ...)
 {
-	char *pathname = get_pathname();
+	char *pathname = get_path_buffer();
 	struct strbuf buf = STRBUF_INIT;
 	const char *git_dir;
 	va_list args;
-- 
2.0.0.526.g5318336
Michal Nazarewicz· Jul 8, 2014, 13:15 UTC · re: Michal Nazarewicz · lore

The get_pathname function does not really return path name but rather a buffer to store pathname in. As such, current name is a bit confusing. Change the name as to make it clearer what the function is doing.

Signed-off-by: Michal Nazarewicz <mina86@mina86.com>
---
 path.c | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)
 This time sent with Junio's correct address.
Show changes to path.c +4 −4
diff --git a/path.c b/path.c
index bc804a3..70e2f85 100644
--- a/path.c
+++ b/path.c
@@ -16,7 +16,7 @@ static int get_st_mode_bits(const char *path, int *mode)
 
 static char bad_path[] = "/bad-path/";
 
-static char *get_pathname(void)
+static char *get_path_buffer(void)
 {
 	static char pathname_array[4][PATH_MAX];
 	static int index;
@@ -108,7 +108,7 @@ char *mkpath(const char *fmt, ...)
 {
 	va_list args;
 	unsigned len;
-	char *pathname = get_pathname();
+	char *pathname = get_path_buffer();
 
 	va_start(args, fmt);
 	len = vsnprintf(pathname, PATH_MAX, fmt, args);
@@ -120,7 +120,7 @@ char *mkpath(const char *fmt, ...)
 
 char *git_path(const char *fmt, ...)
 {
-	char *pathname = get_pathname();
+	char *pathname = get_path_buffer();
 	va_list args;
 	char *ret;
 
@@ -158,7 +158,7 @@ void home_config_paths(char **global, char **xdg, char *file)
 
 char *git_path_submodule(const char *path, const char *fmt, ...)
 {
-	char *pathname = get_pathname();
+	char *pathname = get_path_buffer();
 	struct strbuf buf = STRBUF_INIT;
 	const char *git_dir;
 	va_list args;
-- 
2.0.0.526.g5318336

← back to recent threads