Re: [PATCH v15 05/13] ref-filter: implement an `align` atom
- From
Matthieu Moy <matthieu.moy@grenoble-inp.fr>
- Date
- Sep 2, 2015, 08:45 UTC
- Message-ID
- <vpqvbbttdjm.fsf@anie.imag.fr>
- In-Reply-To
- <1441131994-13508-6-git-send-email-Karthik.188@gmail.com>
Karthik Nayak <karthik.188@gmail.com> writes:
> --- a/ref-filter.c > +++ b/ref-filter.c
Show 5 quoted lines
> @@ -163,9 +174,28 @@ static void quote_formatting(struct strbuf *s, const char *str, int quote_style) > } > } > > +static void align_handler(struct ref_formatting_stack *stack)
Perhaps name it end_align_handler, to make the difference with align_atom_handler clear.
Also, I think moving this function to be right next to align_atom_handler in the code would make this more readable.
Show 12 quoted lines
> @@ -754,6 +816,42 @@ static void populate_value(struct ref_array_item *ref)
> else
> v->s = " ";
> continue;
> + } else if (skip_prefix(name, "align", &valp)) {
> + struct align *align = &v->align;
> + struct strbuf **s;
> +
> + if (valp[0] != ':')
> + die(_("format: usage %%(align:<width>,<position>)"));
> + else
> + valp++;I agree with Junio that skip_prefix(name, "align:" ...) is simpler for the same thing.
> + if (state.stack->prev)
> + die(_("format: `end` atom missing"));Perhaps spell it %(end) instead of just end.
-- Matthieu Moy http://www-verimag.imag.fr/~moy/