Re: [PATCH v2 01/10] ref-filter: implement %(if), %(then), and %(else) atoms
- From
Matthieu Moy <matthieu.moy@grenoble-inp.fr>
- Date
- Oct 8, 2015, 19:19 UTC
- Message-ID
- <vpqsi5lkw1h.fsf@grenoble-inp.fr>
- In-Reply-To
- <1444295885-1657-2-git-send-email-Karthik.188@gmail.com>
Karthik Nayak <karthik.188@gmail.com> writes:
Show 13 quoted lines
> --- a/Documentation/git-for-each-ref.txt > +++ b/Documentation/git-for-each-ref.txt > @@ -134,9 +134,17 @@ align:: > `<position>` is either left, right or middle, default being > left and `<width>` is the total length of the content with > alignment. If the contents length is more than the width then > - no alignment is performed. If used with '--quote' everything > - in between %(align:...) and %(end) is quoted, but if nested > - then only the topmost level performs quoting. > + no alignment is performed. > + > +if:: > + Used as %(if)..%(then)..(%end) or %(if)..%(then)..%(else)..%(end).
I guess you forgot to replace .. with ... (I think you agreed with me that it was better).
Show 7 quoted lines
> @@ -69,10 +72,16 @@ struct contents {
> struct object_id oid;
> };
>
> +struct if_then_else {
> + unsigned int then_atom : 1,
> + else_atom : 1,Maybe "then_atom_seen" and "else_atom_seen" would be better names. Or maybe they'd be too long, I leave it up to you.
-- Matthieu Moy http://www-verimag.imag.fr/~moy/