Re: [PATCH v2 01/10] ref-filter: implement %(if), %(then), and %(else) atoms
- From
Karthik Nayak <karthik.188@gmail.com>
- Date
- Oct 10, 2015, 17:12 UTC
- Message-ID
- <CAOLa=ZTkknFK8ZPEBkuSK2pP3pPoP8MhQ1AumeUqrg6CYp9VWg@mail.gmail.com>
- In-Reply-To
- <vpqsi5lkw1h.fsf@grenoble-inp.fr>
On Fri, Oct 9, 2015 at 12:49 AM, Matthieu Moy <Matthieu.Moy@grenoble-inp.fr> wrote:
Show 19 quoted lines
> Karthik Nayak <karthik.188@gmail.com> writes: > >> --- a/Documentation/git-for-each-ref.txt >> +++ b/Documentation/git-for-each-ref.txt >> @@ -134,9 +134,17 @@ align:: >> `<position>` is either left, right or middle, default being >> left and `<width>` is the total length of the content with >> alignment. If the contents length is more than the width then >> - no alignment is performed. If used with '--quote' everything >> - in between %(align:...) and %(end) is quoted, but if nested >> - then only the topmost level performs quoting. >> + no alignment is performed. >> + >> +if:: >> + Used as %(if)..%(then)..(%end) or %(if)..%(then)..%(else)..%(end). > > I guess you forgot to replace .. with ... (I think you agreed with me > that it was better). >
Oops! I missed this.
Show 11 quoted lines
>> @@ -69,10 +72,16 @@ struct contents {
>> struct object_id oid;
>> };
>>
>> +struct if_then_else {
>> + unsigned int then_atom : 1,
>> + else_atom : 1,
>
> Maybe "then_atom_seen" and "else_atom_seen" would be better names. Or
> maybe they'd be too long, I leave it up to you.
>They do describe the usage in a better way, so why not.
-- Regards, Karthik Nayak