Re: [PATCH] git branch -D: give a better error message when lockfile creation fails
- From
Matthieu Moy <matthieu.moy@grenoble-inp.fr>
- Date
- Sep 26, 2009, 20:12 UTC
- Message-ID
- <vpqr5tt5ut4.fsf@bauges.imag.fr>
- In-Reply-To
- <1253972051-31980-1-git-send-email-vmiklos@frugalware.org>
Miklos Vajna <vmiklos@frugalware.org> writes:
Show 13 quoted lines
> diff --git a/refs.c b/refs.c
> index 24865cf..4eb4fc7 100644
> --- a/refs.c
> +++ b/refs.c
> @@ -972,8 +972,10 @@ static int repack_without_ref(const char *refname)
> if (!found)
> return 0;
> fd = hold_lock_file_for_update(&packlock, git_path("packed-refs"), 0);
> - if (fd < 0)
> + if (fd < 0) {
> + unable_to_lock_index(git_path("packed-refs"), errno, 0);
> return error("cannot delete '%s' from packed refs", refname);
> + }If unable_to_lock_index is called for something other that the index, it should probably be renamed.
Other than that, I like what the patch does (I'm the one who wrote the message for the index ;-) ).
-- Matthieu Moy http://www-verimag.imag.fr/~moy/