Re: [PATCH v6 6/7] config: add `git_die_config()` to the config-set API
- From
Matthieu Moy <matthieu.moy@grenoble-inp.fr>
- Date
- Jul 31, 2014, 15:55 UTC
- Message-ID
- <vpqr411h69h.fsf@anie.imag.fr>
- In-Reply-To
- <1406821662-1570-7-git-send-email-tanayabh@gmail.com>
Tanay Abhra <tanayabh@gmail.com> writes:
Show 14 quoted lines
> +void git_die_config(const char *key)
> +{
> + const struct string_list *values;
> + struct key_value_info *kv_info;
> + values = git_config_get_value_multi(key);
> + kv_info = values->items[values->nr - 1].util;
> + if (!kv_info->linenr)
> + die(_("unable to parse '%s' from command-line config"), key);
> + else
> + die(_("bad config variable '%s' at file line %d in %s"),
> + key,
> + kv_info->linenr,
> + kv_info->filename);
> + }Extra whitespace before }.
Also, didn't we agree that it was a good thing to factor this if/then/else into a helper function?
-- Matthieu Moy http://www-verimag.imag.fr/~moy/