From: Matthieu Moy Date: Thu, 31 Jul 2014 15:55:54 GMT Subject: Re: [PATCH v6 6/7] config: add `git_die_config()` to the config-set API Message-ID: In-Reply-To: <1406821662-1570-7-git-send-email-tanayabh@gmail.com> Tanay Abhra writes: > +void git_die_config(const char *key) > +{ > + const struct string_list *values; > + struct key_value_info *kv_info; > + values = git_config_get_value_multi(key); > + kv_info = values->items[values->nr - 1].util; > + if (!kv_info->linenr) > + die(_("unable to parse '%s' from command-line config"), key); > + else > + die(_("bad config variable '%s' at file line %d in %s"), > + key, > + kv_info->linenr, > + kv_info->filename); > + } Extra whitespace before }. Also, didn't we agree that it was a good thing to factor this if/then/else into a helper function? -- Matthieu Moy http://www-verimag.imag.fr/~moy/