Re: [PATCH v2 2/4] log: add --count option to git log
- From
Matthieu Moy <matthieu.moy@grenoble-inp.fr>
- Date
- Jul 3, 2015, 09:16 UTC
- Message-ID
- <vpqfv5538jw.fsf@anie.imag.fr>
- In-Reply-To
- <CAKDoJU5vHP8c+Cvk1vBjjMG3kHD_rN3XwmfVngMYLN2Tkcg-tQ@mail.gmail.com>
Hi,
Please, don't top-post on this list. Quote the parts you're replying to and reply below.
Lawrence Siebert <lawrencesiebert@gmail.com> writes:
> traverse_commit_list requires a function to be passed to it. That > said, after further review it can probably pass NULL and have it work > fine. If not, I'll use your naming convention.
If possible, passing NULL would be best.
> `git rev-list --count` (or actually `git rev-list --count HEAD`, which > this borrows the code from, produces a single value, a numeric count. > I think walking the entire list is necessary to get the final value, > which is what we want with --count.
OK, that was me answering emails before coffee. I thought --count was producing the count _in addition_ to the normal output. But then I don't understand by looking at the code how you prevent the normal output. I just tested, and indeed it does work (I guess all the magic is already there from "rev-list --count", and it was more or less a bug that "log --count" was not using it properly), but you may want to explain better what's going on in the commit message.
-- Matthieu Moy http://www-verimag.imag.fr/~moy/