Re: [PATCH 1/1] clean: show an error message when the path is too long
- From
Johannes Schindelin <johannes.schindelin@gmx.de>
- Date
- Jul 18, 2019, 08:49 UTC
- Message-ID
- <nycvar.QRO.7.76.6.1907181048280.47@tvgsbejvaqbjf.bet>
- In-Reply-To
- <xmqqsgr4zea9.fsf@gitster-ct.c.googlers.com>
Hi,
On Wed, 17 Jul 2019, Junio C Hamano wrote:
Show 25 quoted lines
> Junio C Hamano <gitster@pobox.com> writes: > > >> The other warnings in that function are issued using > >> warning_errno() (shorter code, consistency is enforced) and > >> messages are marked for translation. That would be nice to have > >> here as well, no? > > > > Absolutely. Also, downcase "Could" and perhaps use _() around. > > > This one is easy enough (not just in the technical sense, but in the > sense that it has little room wasting our time bikeshedding), so let's > tie the loose ends and move on. > > I was tempted to fix the proposed log message to excise exaggeration > (I prefer not to see "very", "important", etc.---other things that is > said in the message should be enough to convince readers about the > importance), but didn't. > > What I did do was to not just rephrasing the warning message, but to > give it its own constant and to feed it to warning_errno(), to match > the other warning message. > > I also saved one (or perhaps two) fork(s) from the test script ;-) and > added a portability note there.
Thanks!
On top, I integrated Gabór's suggestion to use `test_config` and threw in a paragraph in the commit message to explain why the `core.longpaths` variable is touched at all.
v2 incoming, Dscho