Re: [PATCH 2/3] parse-options: add PARSE_OPT_CUSTOM_ARGH for complicated argh's
Stephen Boyd <bebarino@gmail.com> writes:
> Junio C Hamano wrote:
Show 16 quoted lines
> > You are asking a wrong person. I am terrible at naming things; think
> > "rerere" ;-).
> >
> > But I think custom-arghelp is much better than multargs. You are asking
> > "use this help for argument value _literally_", so another possibility
> > perhaps is PARSE_OPT_ARGHELP_LITERAL.
> >
> > After all, there probably are many other valid reasons why you may not
> > want "s/.*/<&>/" blindly applied to your string. One reason may be
> > because the string describes multiple arguments, but I suspect that it is
> > not the only one. It is better to name the option after what it does,
> > than naming it after one sample reason why you might want to use that
> > option.
>
> Ok. I think PARSE_OPT_LITERAL_ARGH might be good; until someone comes up
> with a better one of course.
Well, 'ARGH' sounds a bit strange. I think I'd prefer ARGHELP. :-)
--
Jakub Narebski
Poland
ShadeHawk on #git