Re: [RFC PATCH v2 4/4] read-tree: add --no-sparse to turn off sparse hook
- From
Nguyen Thai Ngoc Duy <pclouds@gmail.com>
- Date
- Aug 11, 2009, 07:08 UTC
- Message-ID
- <fcaeb9bf0908110008g1cbd3442p180557cbe6f24bb1@mail.gmail.com>
- In-Reply-To
- <alpine.DEB.1.00.0908110846050.4638@intel-tinevez-2-302>
On Tue, Aug 11, 2009 at 1:50 PM, Johannes Schindelin<Johannes.Schindelin@gmx.de> wrote:
Show 12 quoted lines
>> Why not making the hook to be skipped by default, and pass an explicit >> option to trigger the hook? >> >> I like Dscho's other suggestion to use patterns like .gitignore instead >> of using hook scripts that needs to be ported across platforms, by the >> way. > > I forgot to mention that I checked dir.c to verify that > add_excludes_from_file_1() (which is static, so you'll either need to use > it in the same file, or even better, export it renaming it to something > like add_excludes_from_file_to_list()) and excluded_1() (same here) > already do a large part of what you need.
Indeed (and I have that code too). I still like the hook though because you have more freedom in defining your worktree (and yes, less portable). I wanted to make something generic enough that you can build higher "strategies" on top, like .gitignore-based patterns. Anyway I'll send out another patch for .gitignore patterns tonight and see how it goes.
-- Duy