Re: [PATCH] Add a built-in alias for 'stage' to the 'add' command
- From
Nguyen Thai Ngoc Duy <pclouds@gmail.com>
- Date
- Dec 2, 2008, 12:36 UTC
- Message-ID
- <fcaeb9bf0812020436n69a21c96g4c13976e493372d9@mail.gmail.com>
- In-Reply-To
- <20081202061455.GA48848@agadorsparticus>
On 12/2/08, Scott Chacon <schacon@gmail.com> wrote:
Show 12 quoted lines
> diff --git a/git.c b/git.c
> index 89feb0b..9e5813c 100644
> --- a/git.c
> +++ b/git.c
> @@ -266,6 +266,7 @@ static void handle_internal_command(int argc, const char **argv)
> const char *cmd = argv[0];
> static struct cmd_struct commands[] = {
> { "add", cmd_add, RUN_SETUP | NEED_WORK_TREE },
> + { "stage", cmd_add, RUN_SETUP | NEED_WORK_TREE },
> { "annotate", cmd_annotate, RUN_SETUP },
> { "apply", cmd_apply },
> { "archive", cmd_archive },Nit-picking. There are some references to "git add" in builtin-add.c, like help usage or error message ("Maybe you wanted to say 'git add .'?\n"). Should it refer to "git stage" instead as well?
-- Duy