Re: [PATCH] Add a built-in alias for 'stage' to the 'add' command
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Dec 3, 2008, 02:18 UTC
- Message-ID
- <7vmyfehuha.fsf@gitster.siamese.dyndns.org>
- In-Reply-To
- <fcaeb9bf0812020436n69a21c96g4c13976e493372d9@mail.gmail.com>
"Nguyen Thai Ngoc Duy" <pclouds@gmail.com> writes:
Show 17 quoted lines
> On 12/2/08, Scott Chacon <schacon@gmail.com> wrote:
>> diff --git a/git.c b/git.c
>> index 89feb0b..9e5813c 100644
>> --- a/git.c
>> +++ b/git.c
>> @@ -266,6 +266,7 @@ static void handle_internal_command(int argc, const char **argv)
>> const char *cmd = argv[0];
>> static struct cmd_struct commands[] = {
>> { "add", cmd_add, RUN_SETUP | NEED_WORK_TREE },
>> + { "stage", cmd_add, RUN_SETUP | NEED_WORK_TREE },
>> { "annotate", cmd_annotate, RUN_SETUP },
>> { "apply", cmd_apply },
>> { "archive", cmd_archive },
>
> Nit-picking. There are some references to "git add" in builtin-add.c,
> like help usage or error message ("Maybe you wanted to say 'git add
> .'?\n"). Should it refer to "git stage" instead as well?I do not think that is necessary. As git-stage(1) makes it clear, it is an alias to "add", not the other way around.