git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH 0/2] For v2.37.0: rename fetch.credentialsInUrl to transfer.credentialsInUrl

From
Derrick Stolee <derrickstolee@github.com>
Date
Jun 15, 2022, 13:12 UTC
Message-ID
<e53a247d-1d12-e34c-6cc8-3813a2fa34dc@github.com>
In-Reply-To
<cover-0.2-00000000000-20220615T103852Z-avarab@gmail.com>
On 6/15/22 6:44 AM, Ævar Arnfjörð Bjarmason wrote:
Show 17 quoted lines
> The $subject is a case where nothing is broken except potential user
> expectations, but as argued in 2/2 I think we really should rename
> this before we kick it out the door.
> 
> Having a "fetch" configuration configure "git push" is really
> confusing, and once we need to support it backing out of it would be a
> hassle.
> 
> Then 1/2 clarifies how it really works, and what it's aimed to do, and
> notes the major caveat that the check doesn't cover "pushurl"
> configuration, which in some setups is the only place you'll put
> passwords in URLs. I think it likewise makes sense to have that in
> v2.37.0 so we won't lull users into a false sense of security.
> 
> This is a relatively large change for an "rc", but the only code
> changes are s/fetch\.credentialsInUrl/transfer.credentialsInUrl/g, the
> rest is all docs.

Sorry that I didn't see this before looking at your other RFC. (That RFC still has some references to "fetch.credentialsInUrl" in your commit messages, btw.)

This rename makes sense and is good to handle before the release. Thank you for updating the release notes.

The expanded details in the docs are good.

Thanks, -Stolee

Previous: Ævar Arnfjörð BjarmasonNext: Junio C Hamano
Message 5 of 6 in “For v2.37.0: rename fetch.credentialsInUrl to transfer.credentialsInUrl”
  1. 0/2 For v2.37.0: rename fetch.credentialsInUrl to transfer.credentialsInUrlÆvar Arnfjörð Bjarmason, Jun 15, 2022
  2. 1/2 fetch doc: note "pushurl" caveat about "credentialsInUrl", elaborateÆvar Arnfjörð Bjarmason, Jun 15, 2022
  3. René ScharfeJun 26, 2022
  4. 2/2 transfer doc: move fetch.credentialsInUrl to "transfer" config namespaceÆvar Arnfjörð Bjarmason, Jun 15, 2022
  5. Derrick StoleeJun 15, 2022
  6. Junio C HamanoJun 15, 2022

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.