Re: [PATCH 00/20] Separate `ref_cache` into a separate module
- From
Michael Haggerty <mhagger@alum.mit.edu>
- Date
- Mar 20, 2017, 22:48 UTC
- Message-ID
- <d2f8af06-1f0f-835e-2535-ce4f754370b1@alum.mit.edu>
- In-Reply-To
- <xmqqk27jtw8w.fsf@gitster.mtv.corp.google.com>
On 03/20/2017 11:32 PM, Junio C Hamano wrote:
Show 31 quoted lines
> Michael Haggerty <mhagger@alum.mit.edu> writes: > >> Michael Haggerty (20): >> get_ref_dir(): don't call read_loose_refs() for "refs/bisect" >> refs_read_raw_ref(): new function >> refs_ref_iterator_begin(): new function >> refs_verify_refname_available(): implement once for all backends >> refs_verify_refname_available(): use function in more places >> Rename `add_ref()` to `add_ref_entry()` >> Rename `find_ref()` to `find_ref_entry()` >> Rename `remove_entry()` to `remove_entry_from_dir()` >> refs: split `ref_cache` code into separate files >> ref-cache: introduce a new type, ref_cache >> refs: record the ref_store in ref_cache, not ref_dir >> ref-cache: use a callback function to fill the cache >> refs: handle "refs/bisect/" in `loose_fill_ref_dir()` >> do_for_each_entry_in_dir(): eliminate `offset` argument >> get_loose_ref_dir(): function renamed from get_loose_refs() >> get_loose_ref_cache(): new function >> cache_ref_iterator_begin(): make function smarter >> commit_packed_refs(): use reference iteration >> files_pack_refs(): use reference iteration >> do_for_each_entry_in_dir(): delete function > > These mostly seem to be ref-cache but there is one mention of "refs > cache", and also the topic cover says ref_cache. Which one is the > canonical one? I'd assume it is "ref-cache" (or "ref cache"). > > The reason I am asking is because I wanted to give the three > "Rename" ones an "<area>:" prefix, and then noticed that the > shortlog output looked somewhat incoherent.
It's meant to be "ref-cache", short for "reference cache", which seems more natural than "references cache". But I admit that I often type it wrong because of muscle memory trained on other things named "refs_blah".
Thanks for noticing.
Michael