Teng Long (1):
list-objects.c: rename "traverse_trees_and_blobs" to
"traverse_non_commits" list-objects.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
Range-diff against v1:
1: b6f3b15253 ! 1: 2d19f0901c list-objects.c: traverse_trees_and_blobs: rename and tree-wide
@@ Metadata
Author: Teng Long <dyroneteng@gmail.com>
## Commit message ##
- list-objects.c: traverse_trees_and_blobs: rename and tree-wide
+ list-objects.c: rename "traverse_trees_and_blobs" to "traverse_non_commits"
Function `traverse_trees_and_blobs` not only works on trees and blobs,
but also on tags, the function name is somewhat misleading. This commit
- rename it to `traverse_trees_and_blobs_and_tags`.
+ rename it to `traverse_non_commits`.
Signed-off-by: Teng Long <dyroneteng@gmail.com>
@@ list-objects.c: static void add_pending_tree(struct rev_info *revs, struct tree
}
-static void traverse_trees_and_blobs(struct traversal_context *ctx,
-+static void traverse_trees_and_blobs_and_tags(struct traversal_context *ctx,
++static void traverse_non_commits(struct traversal_context *ctx,
struct strbuf *base)
{
int i;
@@ list-objects.c: static void do_traverse(struct traversal_context *ctx)
* tree directory without allocation churn?
*/
- traverse_trees_and_blobs(ctx, &csp);
-+ traverse_trees_and_blobs_and_tags(ctx, &csp);
++ traverse_non_commits(ctx, &csp);
}
- traverse_trees_and_blobs(ctx, &csp);
-+ traverse_trees_and_blobs_and_tags(ctx, &csp);
++ traverse_non_commits(ctx, &csp);
strbuf_release(&csp);
}