git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH v1 1/1] list-objects.c: traverse_trees_and_blobs: rename and tree-wide

From
Teng Long <dyroneteng@gmail.com>
Date
Aug 12, 2021, 07:54 UTC
Message-ID
<20210812075415.5114-1-dyroneteng@gmail.com>
In-Reply-To
<xmqqsfzf980v.fsf@gitster.g>
>> Sorry but I do not quite get the " and tree-wide" part of the title.

I may have some misunderstandings about "tree-wide". Sorry, it will be resolved in the next patch.

>>s/trees_and_blobs/non_commits/ will result in a name that is much
>>shorter and to the point, I think.
Agree and thanks for explanation.
Will follow your suggestion in next patch.
I don't know why I didn't think of this naming at the time (*headwalls*).

In fact, I discovered this problem while contributing packfile-uris related features (thinking about excluding tag objects), and finally said to myself "So you are here" (although it didn't take so much effort), So I decide to make this patch.

>>The call to it at the end is meant to sweep anything
>>leftover---we will not discover any tag while in the main loop of
>>the caller that iterates over commits (as they cannot contain any
>>tag in there).
Some doubts.
I think at the object relationship level: tag> commit> tree> blob

The tag is on top because of the annotated tag. So, why the tag is in `revs->pending` to deal? I understand it should be the opposite? A commit should pending to a tag, at least equal.

Maybe my understanding is wrong, if so, why this way?
Thank you.
Previous: Teng LongNext: Teng Long
Message 6 of 11 in “traverse_trees_and_blobs: rename and tree-wide”
  1. 0/1 traverse_trees_and_blobs: rename and tree-wideTeng Long, Aug 11, 2021
  2. 1/1 list-objects.c: traverse_trees_and_blobs: rename and tree-wideTeng Long, Aug 11, 2021
  3. Junio C HamanoAug 11, 2021
  4. Jeff KingAug 11, 2021
  5. Teng LongAug 12, 2021
  6. Teng LongAug 12, 2021
  7. 0/1 list-objects.c: rename "traverse_trees_and_blobs" to "traverse_non_commits"Teng Long, Aug 12, 2021
  8. 1/1 list-objects.c: rename "traverse_trees_and_blobs" to "traverse_non_commits"Teng Long, Aug 12, 2021
  9. 0/1 list-objects.c: rename "traverse_trees_and_blobs" to "traverse_non_commits"Teng Long, Aug 12, 2021
  10. 1/1 list-objects.c: rename "traverse_trees_and_blobs" to "traverse_non_commits"Teng Long, Aug 12, 2021
  11. Jeff KingAug 12, 2021

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.