git/list[1] front-page[2] threads[3] people[4] search[5] about
 

[PATCH v3 00/20] Separate `ref_cache` into a separate module

From
Michael Haggerty <mhagger@alum.mit.edu>
Date
Apr 16, 2017, 06:41 UTC
Message-ID
<cover.1492323985.git.mhagger@alum.mit.edu>

This is v3 of a patch series to separate the reference caching code into a separate module that interacts with `files_ref_cache` more at arm's length. Thanks to Stefan and Duy for their feedback about v2 [1].

This version has only minor changes since v2 (and indeed since v1 [2]):
* Rebased onto the current nd/files-backend-git-dir (there were no
  conflicts).
* Removed redundant assignment in
    refs_verify_refname_available(): implement once for all backends
* Improved two commit messages.

This patch series is also available from my GitHub fork [3] as branch "separate-ref-cache". These patches depend on Duy's nd/files-backend-git-dir branch.

[1] http://public-inbox.org/git/cover.1490966385.git.mhagger@alum.mit.edu/ [2] http://public-inbox.org/git/cover.1490026594.git.mhagger@alum.mit.edu/ [3] https://github.com/mhagger/git

Michael Haggerty (20):
  get_ref_dir(): don't call read_loose_refs() for "refs/bisect"
  refs_read_raw_ref(): new function
  refs_ref_iterator_begin(): new function
  refs_verify_refname_available(): implement once for all backends
  refs_verify_refname_available(): use function in more places
  ref-cache: rename `add_ref()` to `add_ref_entry()`
  ref-cache: rename `find_ref()` to `find_ref_entry()`
  ref-cache: rename `remove_entry()` to `remove_entry_from_dir()`
  refs: split `ref_cache` code into separate files
  ref-cache: introduce a new type, ref_cache
  refs: record the ref_store in ref_cache, not ref_dir
  ref-cache: use a callback function to fill the cache
  refs: handle "refs/bisect/" in `loose_fill_ref_dir()`
  do_for_each_entry_in_dir(): eliminate `offset` argument
  get_loose_ref_dir(): function renamed from get_loose_refs()
  get_loose_ref_cache(): new function
  cache_ref_iterator_begin(): make function smarter
  commit_packed_refs(): use reference iteration
  files_pack_refs(): use reference iteration
  do_for_each_entry_in_dir(): delete function
 Makefile             |    1 +
 refs.c               |  111 ++++-
 refs.h               |    2 +-
 refs/files-backend.c | 1229 +++++++-------------------------------------------
 refs/ref-cache.c     |  523 +++++++++++++++++++++
 refs/ref-cache.h     |  267 +++++++++++
 refs/refs-internal.h |   22 +-
 7 files changed, 1066 insertions(+), 1089 deletions(-)
 create mode 100644 refs/ref-cache.c
 create mode 100644 refs/ref-cache.h
-- 
2.11.0
Next: Michael Haggerty
Message 1 of 21 in “Separate `ref_cache` into a separate module”
  1. 00/20 Separate `ref_cache` into a separate moduleMichael Haggerty, Apr 16, 2017
  2. 01/20 get_ref_dir(): don't call read_loose_refs() for "refs/bisect"Michael Haggerty, Apr 16, 2017
  3. 02/20 refs_read_raw_ref(): new functionMichael Haggerty, Apr 16, 2017
  4. 04/20 refs_verify_refname_available(): implement once for all backendsMichael Haggerty, Apr 16, 2017
  5. 05/20 refs_verify_refname_available(): use function in more placesMichael Haggerty, Apr 16, 2017
  6. 03/20 refs_ref_iterator_begin(): new functionMichael Haggerty, Apr 16, 2017
  7. 07/20 ref-cache: rename `find_ref()` to `find_ref_entry()`Michael Haggerty, Apr 16, 2017
  8. 06/20 ref-cache: rename `add_ref()` to `add_ref_entry()`Michael Haggerty, Apr 16, 2017
  9. 10/20 ref-cache: introduce a new type, ref_cacheMichael Haggerty, Apr 16, 2017
  10. 12/20 ref-cache: use a callback function to fill the cacheMichael Haggerty, Apr 16, 2017
  11. 13/20 refs: handle "refs/bisect/" in `loose_fill_ref_dir()`Michael Haggerty, Apr 16, 2017
  12. 08/20 ref-cache: rename `remove_entry()` to `remove_entry_from_dir()`Michael Haggerty, Apr 16, 2017
  13. 14/20 do_for_each_entry_in_dir(): eliminate `offset` argumentMichael Haggerty, Apr 16, 2017
  14. 15/20 get_loose_ref_dir(): function renamed from get_loose_refs()Michael Haggerty, Apr 16, 2017
  15. 16/20 get_loose_ref_cache(): new functionMichael Haggerty, Apr 16, 2017
  16. 11/20 refs: record the ref_store in ref_cache, not ref_dirMichael Haggerty, Apr 16, 2017
  17. 20/20 do_for_each_entry_in_dir(): delete functionMichael Haggerty, Apr 16, 2017
  18. 19/20 files_pack_refs(): use reference iterationMichael Haggerty, Apr 16, 2017
  19. 18/20 commit_packed_refs(): use reference iterationMichael Haggerty, Apr 16, 2017
  20. 17/20 cache_ref_iterator_begin(): make function smarterMichael Haggerty, Apr 16, 2017
  21. 09/20 refs: split `ref_cache` code into separate filesMichael Haggerty, Apr 16, 2017

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.