git/list[1] front-page[2] threads[3] people[4] search[5] about
 

[PATCH v3 14/20] do_for_each_entry_in_dir(): eliminate `offset` argument

From
Michael Haggerty <mhagger@alum.mit.edu>
Date
Apr 16, 2017, 06:41 UTC
Message-ID
<3fe7a1f3caf6ca2016d2dbdae9ed300429efc880.1492323985.git.mhagger@alum.mit.edu>
In-Reply-To
<cover.1492323985.git.mhagger@alum.mit.edu>
It was never used.
Signed-off-by: Michael Haggerty <mhagger@alum.mit.edu>
---
 refs/files-backend.c |  4 ++--
 refs/ref-cache.c     |  6 +++---
 refs/ref-cache.h     | 11 +++++------
 3 files changed, 10 insertions(+), 11 deletions(-)
diff --git a/refs/files-backend.c b/refs/files-backend.c
index 079ba941ef..c0550ad9d6 100644
--- a/refs/files-backend.c
+++ b/refs/files-backend.c
@@ -1387,7 +1387,7 @@ static int commit_packed_refs(struct files_ref_store *refs)
 
 	fprintf_or_die(out, "%s", PACKED_REFS_HEADER);
 	do_for_each_entry_in_dir(get_packed_ref_dir(packed_ref_cache),
-				 0, write_packed_entry_fn, out);
+				 write_packed_entry_fn, out);
 
 	if (commit_lock_file(packed_ref_cache->lock)) {
 		save_errno = errno;
@@ -1581,7 +1581,7 @@ static int files_pack_refs(struct ref_store *ref_store, unsigned int flags)
 	lock_packed_refs(refs, LOCK_DIE_ON_ERROR);
 	cbdata.packed_refs = get_packed_refs(refs);
 
-	do_for_each_entry_in_dir(get_loose_refs(refs), 0,
+	do_for_each_entry_in_dir(get_loose_refs(refs),
 				 pack_if_possible_fn, &cbdata);
 
 	if (commit_packed_refs(refs))
diff --git a/refs/ref-cache.c b/refs/ref-cache.c
index 44440e0c13..38d4c31985 100644
--- a/refs/ref-cache.c
+++ b/refs/ref-cache.c
@@ -307,18 +307,18 @@ static void sort_ref_dir(struct ref_dir *dir)
 	dir->sorted = dir->nr = i;
 }
 
-int do_for_each_entry_in_dir(struct ref_dir *dir, int offset,
+int do_for_each_entry_in_dir(struct ref_dir *dir,
 			     each_ref_entry_fn fn, void *cb_data)
 {
 	int i;
 	assert(dir->sorted == dir->nr);
-	for (i = offset; i < dir->nr; i++) {
+	for (i = 0; i < dir->nr; i++) {
 		struct ref_entry *entry = dir->entries[i];
 		int retval;
 		if (entry->flag & REF_DIR) {
 			struct ref_dir *subdir = get_ref_dir(entry);
 			sort_ref_dir(subdir);
-			retval = do_for_each_entry_in_dir(subdir, 0, fn, cb_data);
+			retval = do_for_each_entry_in_dir(subdir, fn, cb_data);
 		} else {
 			retval = fn(entry, cb_data);
 		}
diff --git a/refs/ref-cache.h b/refs/ref-cache.h
index ed51e80d88..6eecdf4276 100644
--- a/refs/ref-cache.h
+++ b/refs/ref-cache.h
@@ -258,13 +258,12 @@ struct ref_iterator *cache_ref_iterator_begin(struct ref_dir *dir);
 typedef int each_ref_entry_fn(struct ref_entry *entry, void *cb_data);
 
 /*
- * Call fn for each reference in dir that has index in the range
- * offset <= index < dir->nr.  Recurse into subdirectories that are in
- * that index range, sorting them before iterating.  This function
- * does not sort dir itself; it should be sorted beforehand.  fn is
- * called for all references, including broken ones.
+ * Call `fn` for each reference in `dir`. Recurse into subdirectories,
+ * sorting them before iterating. This function does not sort `dir`
+ * itself; it should be sorted beforehand. `fn` is called for all
+ * references, including broken ones.
  */
-int do_for_each_entry_in_dir(struct ref_dir *dir, int offset,
+int do_for_each_entry_in_dir(struct ref_dir *dir,
 			     each_ref_entry_fn fn, void *cb_data);
 
 /*
-- 
2.11.0
Previous: Michael HaggertyNext: Michael Haggerty
Message 13 of 21 in “Separate `ref_cache` into a separate module”
  1. 00/20 Separate `ref_cache` into a separate moduleMichael Haggerty, Apr 16, 2017
  2. 01/20 get_ref_dir(): don't call read_loose_refs() for "refs/bisect"Michael Haggerty, Apr 16, 2017
  3. 02/20 refs_read_raw_ref(): new functionMichael Haggerty, Apr 16, 2017
  4. 04/20 refs_verify_refname_available(): implement once for all backendsMichael Haggerty, Apr 16, 2017
  5. 05/20 refs_verify_refname_available(): use function in more placesMichael Haggerty, Apr 16, 2017
  6. 03/20 refs_ref_iterator_begin(): new functionMichael Haggerty, Apr 16, 2017
  7. 07/20 ref-cache: rename `find_ref()` to `find_ref_entry()`Michael Haggerty, Apr 16, 2017
  8. 06/20 ref-cache: rename `add_ref()` to `add_ref_entry()`Michael Haggerty, Apr 16, 2017
  9. 10/20 ref-cache: introduce a new type, ref_cacheMichael Haggerty, Apr 16, 2017
  10. 12/20 ref-cache: use a callback function to fill the cacheMichael Haggerty, Apr 16, 2017
  11. 13/20 refs: handle "refs/bisect/" in `loose_fill_ref_dir()`Michael Haggerty, Apr 16, 2017
  12. 08/20 ref-cache: rename `remove_entry()` to `remove_entry_from_dir()`Michael Haggerty, Apr 16, 2017
  13. 14/20 do_for_each_entry_in_dir(): eliminate `offset` argumentMichael Haggerty, Apr 16, 2017
  14. 15/20 get_loose_ref_dir(): function renamed from get_loose_refs()Michael Haggerty, Apr 16, 2017
  15. 16/20 get_loose_ref_cache(): new functionMichael Haggerty, Apr 16, 2017
  16. 11/20 refs: record the ref_store in ref_cache, not ref_dirMichael Haggerty, Apr 16, 2017
  17. 20/20 do_for_each_entry_in_dir(): delete functionMichael Haggerty, Apr 16, 2017
  18. 19/20 files_pack_refs(): use reference iterationMichael Haggerty, Apr 16, 2017
  19. 18/20 commit_packed_refs(): use reference iterationMichael Haggerty, Apr 16, 2017
  20. 17/20 cache_ref_iterator_begin(): make function smarterMichael Haggerty, Apr 16, 2017
  21. 09/20 refs: split `ref_cache` code into separate filesMichael Haggerty, Apr 16, 2017

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.