Re: [PATCH 5/5] load_ref_decorations(): avoid parsing non-tag objects
- From
Derrick Stolee <stolee@gmail.com>
- Date
- Jun 22, 2021, 17:25 UTC
- Message-ID
- <c4c27819-157c-d694-d758-8dbb46499ab3@gmail.com>
- In-Reply-To
- <YNIZRlTic6K+6rvf@coredump.intra.peff.net>
On 6/22/2021 1:09 PM, Jeff King wrote:
Show 17 quoted lines
> On Tue, Jun 22, 2021 at 01:06:48PM -0400, Jeff King wrote: > >>> Do you mean "if (objtype < 0)" here? There is a 'type' variable, >>> but it is an enum decoration_type and I can't find a reason why >>> it would be negative. oid_object_info() _does_ return -1 if there >>> is a problem loading the object, so that would make sense. >> >> Whoops, thanks for catching that. I originally called it "enum >> object_type type", but then of course the compiler informed that there >> was already a "type" variable in the function. So I renamed it to >> "objtype" but missed updating that line. But it still compiled. Yikes. :) >> >> It doesn't trigger in the test suite because it only happens if the >> repository is corrupted. > > I'm tempted by this as a cleanup on top (I don't want to do it inline, > since the diff is so noisy). But I'm also content to leave it.
Naming is hard. This change seems worth it.
Thanks, -Stolee