Re: [RFC PATCH] Record a single transaction for conflicting push operations
- From
Karl Wiberg <kha@treskal.com>
- Date
- Dec 21, 2009, 07:08 UTC
- Message-ID
- <b8197bcb0912202308p296207av416cd5590a11251b@mail.gmail.com>
- In-Reply-To
- <b0943d9e0912201521k73bdcb5fl333e845028954050@mail.gmail.com>
On Mon, Dec 21, 2009 at 12:21 AM, Catalin Marinas <catalin.marinas@gmail.com> wrote:
Show 12 quoted lines
> 2009/12/19 Karl Wiberg <kha@treskal.com>: > >> Better. But couldn't you remove the update function completely and >> just inline the code in it, since it's called immediately? > > Of course, I tried, but couldn't get it to work. I get HEAD and top > not equal unless I call update() between _TransPatchMap and > self.__halt(). For the non-conflicting case we need to call update > before or after this "if merge_conflict". > > One solution is to split the "if merge_conflict" in two but maybe > you have a better idea.
Yes, duplicating the conditional was what I had in mind. But if you don't find it to improve the readability of the code (as compared to having a function), I certainly won't insist.
Thanks for working on this.
By the way, you do realize there's another command that requires two steps to undo completely: refresh? And that one is harder to get out of---undoing it all in one step would mean throwing away the updates to the patch.
-- Karl Wiberg, kha@treskal.com subrabbit.wordpress.com www.treskal.com/kalle