git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: Removing duplicated code between builtin-send-pack.c and transport.c

From
Daniel Barkalow <barkalow@iabervon.org>
Date
Apr 22, 2009, 18:24 UTC
Message-ID
<alpine.LNX.1.00.0904221407160.10753@iabervon.org>
In-Reply-To
<09511913-0ED3-41C0-A4F0-9F2D452C00D7@petdance.com>
On Wed, 22 Apr 2009, Andy Lester wrote:
Show 5 quoted lines
> There's a ton of code duplicated between transport.c and builtin-send-pack.c,
> from print_push_status() and its static helpers.
> 
> Is there a reason NOT to refactor it out of the builtin and use the 
> transport? 

I think the builtin should actually just be deprecated and eventually removed. As far as I know, nothing actually runs "git send-pack" rather than calling send_pack(), but I left the builtin entry point, along with its helpers, just in case.

If you're interested in reorganizing things there, I think it would be best to move send_pack() to a new send-pack.c, such that builtin-send-pack.c can go away entirely.

	-Daniel
*This .sig left intentionally blank*
Previous: Andy LesterNext: Jeff King
Message 2 of 7 in “Removing duplicated code between builtin-send-pack.c and transport.c”
  1. Andy LesterApr 22, 2009
  2. Daniel BarkalowApr 22, 2009
  3. Jeff KingApr 22, 2009
  4. Andy LesterApr 22, 2009
  5. Jeff KingApr 22, 2009
  6. Andy LesterApr 22, 2009
  7. Jeff KingApr 22, 2009

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.