git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCHv2 3/4] Documentation: branch.*.merge can also afect 'git-push'

From
SBSanti Béjar <santi@agolina.net>
Date
Mar 30, 2009, 22:06 UTC
Message-ID
<adf1fd3d0903301506r65bd9b9bv6bf76c652a051400@mail.gmail.com>
In-Reply-To
<7vd4bzdkkq.fsf@gitster.siamese.dyndns.org>
2009/3/30 Junio C Hamano <gitster@pobox.com>:
> I'll take [1/4] and [2/4] with minor rewording, and I think [4/4] is not
> necessary (push.default is clear enough---and defaultMode won't make it
> any clearer to the first time readers anyway as it is unspecified what
> kind of "mode" it is talking about).

At least to me, mode in the context of 'push' suggest behavior. But maybe only for second time readers...

Show 6 quoted lines
>
> I do not understand this [3/4].  I did look at push.default but it is
> unclear how this variable is involved.
>
> Perhaps it is because the word "tracking" in the description "push the
> current branch to the branch it is tracking" is used without explaination.

Maybe the push.default description needs some enhancements, but this [3/4] is true.

> I think the author meant to say if your local branch frotz by default
> merges changes made to the branch nitfol of the remote repository, "frotz
> tracks nitfol", but the use of the word "track" for that meaning appears
> nowhere in Documentation/glossary-content.txt
So we can define:
push.default = "tracking" = "push the current branch to its upstream branch"

The "upstream branch" is defined in branch.name.merge and could also be added to glossary-content.

Santi
Previous: Junio C HamanoNext: Junio C Hamano
Message 7 of 17 in “[PATCHv2 0/4] push.default and branch.<name>.{remote,merge} changes”
  1. Santi BéjarMar 30, 2009
  2. 1/4 Documentation: enhance branch.<name>.{remote,merge}Santi Béjar, Mar 30, 2009
  3. 2/4 Documentation: push.default applies to all remotesSanti Béjar, Mar 30, 2009
  4. 3/4 Documentation: branch.*.merge can also afect 'git-push'Santi Béjar, Mar 30, 2009
  5. Michael J GruberMar 30, 2009
  6. Junio C HamanoMar 30, 2009
  7. Santi BéjarMar 30, 2009
  8. Junio C HamanoApr 2, 2009
  9. 4/4 Rename push.default to push.modeSanti Béjar, Mar 30, 2009
  10. Michael J GruberMar 30, 2009
  11. Santi BéjarMar 30, 2009
  12. Michael J GruberMar 30, 2009
  13. Jeff KingMar 30, 2009
  14. Michael J GruberMar 30, 2009
  15. Jeff KingMar 30, 2009
  16. Michael J GruberMar 31, 2009
  17. Jeff KingMar 31, 2009

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.