Re: What's cooking in git.git (Jul 2025, #01; Tue, 1)
- From
Patrick Steinhardt <ps@pks.im>
- Date
- Jul 2, 2025, 02:42 UTC
- Message-ID
- <aGScqbG2SGSK8Hwg@pks.im>
- In-Reply-To
- <xmqqwm8rh00m.fsf@gitster.g>
On Tue, Jul 01, 2025 at 06:08:57PM -0700, Junio C Hamano wrote:
Show 23 quoted lines
> * ps/object-store (2025-07-01) 17 commits
> - odb: rename `read_object_with_reference()`
> - odb: rename `pretend_object_file()`
> - odb: rename `has_object()`
> - odb: rename `repo_read_object_file()`
> - odb: rename `oid_object_info()`
> - odb: trivial refactorings to get rid of `the_repository`
> - odb: get rid of `the_repository` when handling submodule sources
> - odb: get rid of `the_repository` when handling the primary source
> - odb: get rid of `the_repository` in `for_each()` functions
> - odb: get rid of `the_repository` when handling alternates
> - odb: get rid of `the_repository` in `odb_mkstemp()`
> - odb: get rid of `the_repository` in `assert_oid_type()`
> - odb: get rid of `the_repository` in `find_odb()`
> - odb: introduce parent pointers
> - object-store: rename files to "odb.{c,h}"
> - object-store: rename `object_directory` to `odb_source`
> - object-store: rename `raw_object_store` to `object_database`
>
> Code clean-up around object access API.
>
> Comments?
> source: <20250701-pks-object-store-wo-the-repository-v6-0-dbf3894ab4e2@pks.im>From my point of view this should be good enough now. The only contentious point really was the renaming of `struct object_directory`. The current iteration of `struct odb_source` seems to be something that everyone can agree to, so I don't plan to iterate on this series any further.
Patrick