Re: [PATCH] Trivial fix: Make all the builtin usage strings to use the same pattern.
- From
Thiago Farina <tfransosi@gmail.com>
- Date
- Sep 21, 2009, 21:39 UTC
- Message-ID
- <a4c8a6d00909211439j3638d924xedccd4c2f8702261@mail.gmail.com>
- In-Reply-To
- <4AB7A534.2070406@viscovery.net>
On Mon, Sep 21, 2009 at 1:09 PM, Johannes Sixt <j.sixt@viscovery.net> wrote:
Show 14 quoted lines
> Thiago Farina schrieb: >> They follow the pattern of file name: >> File name pattern: builtin-command-name.c >> Usage string pattern: builtin_command_name_usage > > Well, file names are not so constant: every now and then an external > command is turned into a builtin (and the filename is changed), and we > have even seen that a builtin was turned into an external command. > Moreover, some commands are implemented in the same file, for example 'git > log' and 'git show'. How about naming the variable after the command name? > E.g.: > > command: git cat-file > variable: git_cat_file_usage
That sounds good, I will follow this pattern in the next patch. So all existing builtin_command_name_usage will be changed to git_command_name_usage, command_name_usage to git_command_name_usage, etc.