Re: [PATCH v2 06/10] pack-bitmap: allow passing payloads to `show_reachable_fn()`
- From
Patrick Steinhardt <ps@pks.im>
- Date
- Apr 2, 2025, 11:13 UTC
- Message-ID
- <Z-0bxM6AjLDAjDx2@pks.im>
- In-Reply-To
- <87h638f54w.fsf@iotcl.com>
On Tue, Apr 01, 2025 at 02:17:03PM +0200, Toon Claes wrote:
Show 15 quoted lines
> Patrick Steinhardt <ps@pks.im> writes: > > diff --git a/pack-bitmap.c b/pack-bitmap.c > > index 6f7fd94c36f..d192fb87da9 100644 > > --- a/pack-bitmap.c > > +++ b/pack-bitmap.c > > @@ -1663,7 +1663,8 @@ static void init_type_iterator(struct ewah_or_iterator *it, > > static void show_objects_for_type( > > struct bitmap_index *bitmap_git, > > enum object_type object_type, > > - show_reachable_fn show_reach) > > + show_reachable_fn show_reach, > > What would you think about adding the `_fn` to `show_reach`? Because the > function is passed on to `show_objects_for_type()`, I think it improves > the readability if it's called `show_reach_fn` or somethin?g
We don't have that suffix anywhere else where `show_reachable_fn` is accepted. So for the sake of consistency I'd rather leave it this way.
Patrick