Re: [PATCH v2 06/10] pack-bitmap: allow passing payloads to `show_reachable_fn()`
- From
Toon Claes <toon@iotcl.com>
- Date
- Apr 1, 2025, 12:17 UTC
- Message-ID
- <87h638f54w.fsf@iotcl.com>
- In-Reply-To
- <20250327-pks-cat-file-object-type-filter-v2-6-4bbc7085d7c5@pks.im>
Patrick Steinhardt <ps@pks.im> writes:
Show 64 quoted lines
> The `show_reachable_fn` callback is used by a couple of functions to
> present reachable objects to the caller. The function does not provide a
> way for the caller to pass a payload though, which is functionality that
> we'll require in a subsequent commit.
>
> Change the callback type to accept a payload and adapt all callsites
> accordingly.
>
> Signed-off-by: Patrick Steinhardt <ps@pks.im>
> ---
> builtin/pack-objects.c | 3 ++-
> builtin/rev-list.c | 3 ++-
> pack-bitmap.c | 15 ++++++++-------
> pack-bitmap.h | 3 ++-
> reachable.c | 3 ++-
> 5 files changed, 16 insertions(+), 11 deletions(-)
>
> diff --git a/builtin/pack-objects.c b/builtin/pack-objects.c
> index a7e4bb79049..38784613fc0 100644
> --- a/builtin/pack-objects.c
> +++ b/builtin/pack-objects.c
> @@ -1736,7 +1736,8 @@ static int add_object_entry(const struct object_id *oid, enum object_type type,
> static int add_object_entry_from_bitmap(const struct object_id *oid,
> enum object_type type,
> int flags UNUSED, uint32_t name_hash,
> - struct packed_git *pack, off_t offset)
> + struct packed_git *pack, off_t offset,
> + void *payload UNUSED)
> {
> display_progress(progress_state, ++nr_seen);
>
> diff --git a/builtin/rev-list.c b/builtin/rev-list.c
> index bb26bee0d45..1100dd2abe7 100644
> --- a/builtin/rev-list.c
> +++ b/builtin/rev-list.c
> @@ -429,7 +429,8 @@ static int show_object_fast(
> int exclude UNUSED,
> uint32_t name_hash UNUSED,
> struct packed_git *found_pack UNUSED,
> - off_t found_offset UNUSED)
> + off_t found_offset UNUSED,
> + void *payload UNUSED)
> {
> fprintf(stdout, "%s\n", oid_to_hex(oid));
> return 1;
> diff --git a/pack-bitmap.c b/pack-bitmap.c
> index 6f7fd94c36f..d192fb87da9 100644
> --- a/pack-bitmap.c
> +++ b/pack-bitmap.c
> @@ -1625,7 +1625,7 @@ static void show_extended_objects(struct bitmap_index *bitmap_git,
> (obj->type == OBJ_TAG && !revs->tag_objects))
> continue;
>
> - show_reach(&obj->oid, obj->type, 0, eindex->hashes[i], NULL, 0);
> + show_reach(&obj->oid, obj->type, 0, eindex->hashes[i], NULL, 0, NULL);
> }
> }
>
> @@ -1663,7 +1663,8 @@ static void init_type_iterator(struct ewah_or_iterator *it,
> static void show_objects_for_type(
> struct bitmap_index *bitmap_git,
> enum object_type object_type,
> - show_reachable_fn show_reach)
> + show_reachable_fn show_reach,What would you think about adding the `_fn` to `show_reach`? Because the function is passed on to `show_objects_for_type()`, I think it improves the readability if it's called `show_reach_fn` or somethin?g
-- Toon