Re: [PATCH 10/12] cache.h & test-tool.h: add & use "USE_THE_INDEX_VARIABLE"
- From
Taylor Blau <me@ttaylorr.com>
- Date
- Nov 18, 2022, 18:41 UTC
- Message-ID
- <Y3fR7NMkfVKtfB4J@nand.local>
- In-Reply-To
- <patch-10.12-9eda7916e75-20221118T112205Z-avarab@gmail.com>
On Fri, Nov 18, 2022 at 12:31:04PM +0100, Ævar Arnfjörð Bjarmason wrote:
Show 15 quoted lines
> In a preceding commit we fully applied the > "index-compatibility.pending.cocci" rule to "t/helper/*". Let's now > stop defining "USE_THE_INDEX_COMPATIBILITY_MACROS" in test-tool.h > itself, and instead instead move the define to the individual test > helpers that need it. This mirrors how we do the same thing in the > "builtin/" directory. > > We could start using "USE_THE_INDEX_COMPATIBILITY_MACROS", but let's > instead introduce a narrow version of it named > "USE_THE_INDEX_VARIABLE". As the name suggests this doesn't give us > any of the compatibility macros, but only "the_index" variable. > > Eventually we'll move other outstanding users of > "USE_THE_INDEX_COMPATIBILITY_MACROS" over to using this more narrow > and descriptive define.
The above two paragraphs look like they belong in the previous commit, no?
Otherwise the rest of the changes here look reasonable.
Thanks, Taylor