Re: bad git pull
- From
Nicolas Pitre <nico@cam.org>
- Date
- Dec 18, 2005, 04:17 UTC
- Message-ID
- <Pine.LNX.4.64.0512172310060.26663@localhost.localdomain>
- In-Reply-To
- <7v8xujyuna.fsf@assigned-by-dhcp.cox.net>
On Sat, 17 Dec 2005, Junio C Hamano wrote:
Show 6 quoted lines
> Nicolas Pitre <nico@cam.org> writes: > > > One observation is that ORIG_HEAD should probably be named PREV_HEAD in > > such context to make it more obvious what it is about. > > I do not see much difference either way,
ORIG suggests "origin" to me, something that was there first, or before anything else. If you want to undo something, you want its "previous" state restored relative to the current state, not the absolute previous (first) one.
> but I suspect ORIG_HEAD > is pretty much well established by now.
Well, cogito for one doesn't care at all, and it even doesn't make for it to be created/updated.
But still it can remain for what it is now, and PREV_HEAD added for undo purpose.
Not a big deal in any case though.
Nicolas