Re: [PATCH] Add git-config --remove-section, document --rename-section
- From
Johannes Schindelin <johannes.schindelin@gmx.de>
- Date
- Mar 1, 2007, 22:46 UTC
- Message-ID
- <Pine.LNX.4.63.0703012344270.22628@wbgn013.biozentrum.uni-wuerzburg.de>
- In-Reply-To
- <es66vt$jej$1@sea.gmane.org>
Hi,
On Thu, 1 Mar 2007, Paolo Bonzini wrote:
> As per the subject. The existing --rename-section option is > undocumented, while --remove-section is added by this patch based on the > code I had written for the "git branch" patch.
Am I right assuming that you copied rename_section(), and modified it to be remove_section()?
How about modifying rename_section() so that if new_name == NULL, it removes the section?
But I like the way you extracted section_name_match(). Makes the code much more readable.
Ciao, Dscho