git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH v4 2/2] repo: add new flag --keys to git-repo-info

From
Lucas Seiki Oshiro <lucasseikioshiro@gmail.com>
Date
Jan 21, 2026, 14:38 UTC
Message-ID
<E8095CC7-E913-4012-8036-DD2FC5A0E290@gmail.com>
In-Reply-To
<aXB9976b3Oqf-_Tp@pks.im>
Show 7 quoted lines
> I also thought about it, but didn't want to propose it myself. But I
> agree that this would be a reasonable change. After all, git-repo(1) is
> still young and it's marked as experimental, so from my perspective it
> is fair to do adjustments like this once we notice that we've been a bit
> too narrow-minded.
> 
> So I'm all for it.

Agreed. And I think that it makes more sense than adding a new output format only for --keys and extra checks in other places.

Besides this, I sent first patch of this series (the "default" output format) to support -z with --keys [1]. If we change "keyvalue" to "lines" maybe it wouldn't be useful.

So, now I'm thinking about dropping the first patch and replacing it by a new one renaming "keyvalue" to "lines".

[1] https://lore.kernel.org/git/5A4D4433-FD38-4BB0-81B6-3BAD33A30A74@gmail.com/
Previous: Patrick SteinhardtNext: Junio C Hamano
Message 28 of 40 in “repo: add new flag --keys to git-repo-info”
  1. repo: add new flag --keys to git-repo-infoLucas Seiki Oshiro, Dec 7, 2025
  2. Junio C HamanoDec 7, 2025
  3. Lucas Seiki OshiroDec 8, 2025
  4. Patrick SteinhardtDec 8, 2025
  5. 0/2 repo: add new flag --keys to git-repo-infoLucas Seiki Oshiro, Dec 9, 2025
  6. 1/2 repo: add a default output format to enum output_formatLucas Seiki Oshiro, Dec 9, 2025
  7. Patrick SteinhardtJan 5, 2026
  8. Lucas Seiki OshiroJan 7, 2026
  9. Patrick SteinhardtJan 8, 2026
  10. 2/2 repo: add new flag --keys to git-repo-infoLucas Seiki Oshiro, Dec 9, 2025
  11. Patrick SteinhardtJan 5, 2026
  12. Lucas Seiki OshiroJan 5, 2026
  13. Patrick SteinhardtJan 5, 2026
  14. 0/2 repo: add --format=default and --keysLucas Seiki Oshiro, Jan 9, 2026
  15. Junio C HamanoJan 10, 2026
  16. Junio C HamanoJan 10, 2026
  17. 1/2 repo: add a default output format to enum output_formatLucas Seiki Oshiro, Jan 9, 2026
  18. 2/2 repo: add new flag --keys to git-repo-infoLucas Seiki Oshiro, Jan 9, 2026
  19. Jean-Noël AVILAJan 10, 2026
  20. Lucas Seiki OshiroJan 10, 2026
  21. Patrick SteinhardtJan 12, 2026
  22. 0/2 repo: add --format=default and --keysLucas Seiki Oshiro, Jan 19, 2026
  23. 1/2 repo: add a default output format to enum output_formatLucas Seiki Oshiro, Jan 19, 2026
  24. 2/2 repo: add new flag --keys to git-repo-infoLucas Seiki Oshiro, Jan 19, 2026
  25. Patrick SteinhardtJan 20, 2026
  26. Lucas Seiki OshiroJan 20, 2026
  27. Patrick SteinhardtJan 21, 2026
  28. Lucas Seiki OshiroJan 21, 2026
  29. Junio C HamanoJan 20, 2026
  30. 0/2 repo: add --keys and rename "keyvalue" to "lines"Lucas Seiki Oshiro, Jan 23, 2026
  31. 1/2 repo: rename "keyvalue" to "lines"Lucas Seiki Oshiro, Jan 23, 2026
  32. Patrick SteinhardtJan 27, 2026
  33. 2/2 repo: add new flag --keys to git-repo-infoLucas Seiki Oshiro, Jan 23, 2026
  34. Patrick SteinhardtJan 27, 2026
  35. Lucas Seiki OshiroJan 27, 2026
  36. 0/2 repo: add --keys and rename "keyvalue" to "lines"Lucas Seiki Oshiro, Feb 14, 2026
  37. 1/2 repo: rename the output format "keyvalue" to "lines"Lucas Seiki Oshiro, Feb 14, 2026
  38. 2/2 repo: add new flag --keys to git-repo-infoLucas Seiki Oshiro, Feb 14, 2026
  39. Junio C HamanoFeb 14, 2026
  40. Patrick SteinhardtFeb 16, 2026

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.