Re: [PATCH] fetch: remove fetch_if_missing=0
- From
Eric Sunshine <sunshine@sunshineco.com>
- Date
- Nov 2, 2019, 06:11 UTC
- Message-ID
- <CAPig+cTqKe7Xz4tZrA+sC7peVdjaVS1wQfJ4fLVVUzVzjHdrmw@mail.gmail.com>
- In-Reply-To
- <xmqqv9s23jr5.fsf@gitster-ct.c.googlers.com>
On Sat, Nov 2, 2019 at 1:55 AM Junio C Hamano <gitster@pobox.com> wrote:
Show 14 quoted lines
> Jonathan Nieder <jrnieder@gmail.com> writes: > > nit: can avoid a subshell: > > > > test_seq 1 100 | sed -e 's/^/line /' >big-blob.txt > > Yeah, but it costs process start-up and "sed" that may be rather > heavyweight. At least > > for i in $(test_seq ...) > do > echo line $i > done >big-blob.txt > > would save repeated opening and closing the file, I'd think.
More bikeshedding:
printf "line %d\n" $(test_seq 1 100) >big-blob.txt
is reasonably concise, perhaps easier to grok than the one-liner incorporating 'sed', and shouldn't run afoul of command-line length limitation.