Re: [PATCH 1/3] config.txt: Clarify allowTipSHA1InWant with camelCase
- From
Eric Sunshine <sunshine@sunshineco.com>
- Date
- May 12, 2015, 21:24 UTC
- Message-ID
- <CAPig+cTc7qE_tD2-DtpnMGrSFthwaGakFnOWAtkq=a5aOQNMbQ@mail.gmail.com>
- In-Reply-To
- <1431465265-18486-1-git-send-email-fredrik.medley@gmail.com>
On Tue, May 12, 2015 at 5:14 PM, Fredrik Medley <fredrik.medley@gmail.com> wrote:
> Most of the options in config.txt are camelCase. Improve the readability > for allowtipsha1inwant by changing to allowTipSHA1InWant.
Missing sign-off. More below.
Show 14 quoted lines
> --- > diff --git a/Documentation/config.txt b/Documentation/config.txt > index 2e5ceaf..2b86fe6 100644 > --- a/Documentation/config.txt > +++ b/Documentation/config.txt > @@ -2530,9 +2530,9 @@ uploadpack.hideRefs:: > are under the hierarchies listed on the value of this > variable is excluded, and is hidden from `git ls-remote`, > `git fetch`, etc. An attempt to fetch a hidden ref by `git > - fetch` will fail. See also `uploadpack.allowtipsha1inwant`. > + fetch` will fail. See also `uploadpack.allowTipSHA1InWant`. > > -uploadpack.allowtipsha1inwant:: > +uploadpack.allowTipSHA1InWant::
This was already attempted here[1]; some inconsistencies with acronyms and abbreviations pointed out here[2]; and delayed here[3]. Perhaps it's now time to revisit the acronyms/abbreviations issue?
[1]: http://thread.gmane.org/gmane.comp.version-control.git/265225/focus=265225 [2]: http://thread.gmane.org/gmane.comp.version-control.git/265225/focus=265262 [3]: http://thread.gmane.org/gmane.comp.version-control.git/265225/focus=265282
Show 5 quoted lines
> When `uploadpack.hideRefs` is in effect, allow `upload-pack` > to accept a fetch request that asks for an object at the tip > of a hidden ref (by default, such a request is rejected). > -- > 1.9.1