Re: [GSoC][PATCH v3 0/3] Use helper functions in test script
- From
Eric Sunshine <sunshine@sunshineco.com>
- Date
- Mar 5, 2019, 00:09 UTC
- Message-ID
- <CAPig+cSsAufCnHPJfjQd8A778UNAsXEst1m+ekQ7T83=2mMUnw@mail.gmail.com>
- In-Reply-To
- <20190304120801.28763-1-rohit.ashiwal265@gmail.com>
On Mon, Mar 4, 2019 at 7:08 AM Rohit Ashiwal <rohit.ashiwal265@gmail.com> wrote:
Show 7 quoted lines
> This patch ultimately aims to replace `test -(d|f|e|s)` calls in t3600-rm.sh > Previously we were using these to verify the presence of diretory/file, but > we already have helper functions, viz, `test_path_is_dir`, `test_path_is_file`, > `test_path_is_missing` and `test_file_not_empty` with better functionality > > Helper functions are better as they provide better error messages and > improve readability. They are friendly to someone new to code.
As an aid to reviewers, please use the cover-letter to explain what changed since the previous version of the patch series. Also, to further help reviewers, consider using the --range-diff or --interdiff options with "git format-patch" to visually show the changes since the previous attempt (in addition to your prose explanation).
Finally, it is a good idea to provide a link, like this[1], to the previous round in order to jog the memory of existing reviewers and to provide context for people new to the review of the series.
[1]: https://public-inbox.org/git/20190303233750.6500-1-rohit.ashiwal265@gmail.com/