[GSoC][PATCH v3 0/3] Use helper functions in test script
- From
Rohit Ashiwal <rohit.ashiwal265@gmail.com>
- Date
- Mar 4, 2019, 12:07 UTC
- Message-ID
- <20190304120801.28763-1-rohit.ashiwal265@gmail.com>
- In-Reply-To
- <20190303122842.30380-1-rohit.ashiwal265@gmail.com>
This patch ultimately aims to replace `test -(d|f|e|s)` calls in t3600-rm.sh Previously we were using these to verify the presence of diretory/file, but we already have helper functions, viz, `test_path_is_dir`, `test_path_is_file`, `test_path_is_missing` and `test_file_not_empty` with better functionality
Helper functions are better as they provide better error messages and improve readability. They are friendly to someone new to code.
Rohit Ashiwal (3): test functions: add function `test_file_not_empty` t3600: modernize style t3600: use helpers to replace test -d/f/e/s <path>
t/t3600-rm.sh | 349 ++++++++++++++++++++-------------------- t/test-lib-functions.sh | 9 ++ 2 files changed, 187 insertions(+), 171 deletions(-)
-- Rohit