git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [GSOC][RFC PATCH 0/1] microproject: use test_path_is_* functions in test scripts

From
Eric Sunshine <sunshine@sunshineco.com>
Date
Feb 19, 2024, 19:36 UTC
Message-ID
<CAPig+cSOsGAizKJdeX9Qb45LqsKOzpEO+1Pxhd2e205ndeHngg@mail.gmail.com>
In-Reply-To
<20240219172214.7644-1-vincenzo.mezzela@gmail.com>

On Mon, Feb 19, 2024 at 12:22 PM Vincenzo Mezzela <vincenzo.mezzela@gmail.com> wrote:

Show 17 quoted lines
> Would you like to see something like
> '''
> test_path_is_missing file1 &&
> test_path_is_file file2 &&
> test_path_is_missing file3 &&
> test_path_is_file file5
> '''
> changed into
> '''
> test_path_is_file file2 &&
> test_path_is_file file5 &&
> test_path_is_missing file3 &&
> test_path_is_missing file1
> '''
> where all the test_path_is_file are grouped before and followed by all
> the test_path_is_missing (or the other way around) to enhance
> readability of the code?

Generally speaking, no, reviewers would not want to see such a change because "enhanced readability" is often quite subjective. More importantly, though, reviewers would especially not want this done in the same patch which changes `test -blah` to `test_path_foo` because it make it harder for the reviewer to associate and verify each `test -blah` to `test_path_foo` replacement in the final result with the source statement in the original file. It's much easier for a reviewer to validate old against new when there is an obvious one-to-one correspondence.

Previous: Christian CouderNext: Vincenzo Mezzela
Message 4 of 14 in “microproject: use test_path_is_* functions in test scripts”
  1. Vincenzo MezzelaFeb 19, 2024
  2. [GSOC][RFC PATCH 1/1] t: t7301-clean-interactive: Use test_path_is_(missing|file)Vincenzo Mezzela, Feb 19, 2024
  3. Christian CouderFeb 26, 2024
  4. Eric SunshineFeb 19, 2024
  5. [GSOC][PATCH v2 0/1] microproject: use test_path_is_* functions in test scriptsVincenzo Mezzela, Feb 27, 2024
  6. [GSOC][PATCH v2 1/1] t7301: use test_path_is_(missing|file)Vincenzo Mezzela, Feb 27, 2024
  7. Patrick SteinhardtMar 4, 2024
  8. [GSOC][PATCH v3 0/1] microproject: use test_path_is_* functions in test scriptsVincenzo Mezzela, Mar 4, 2024
  9. [GSOC][PATCH v3 1/1] t7301: use test_path_is_(missing|file)Vincenzo Mezzela, Mar 4, 2024
  10. Junio C HamanoMar 4, 2024
  11. Eric SunshineMar 4, 2024
  12. [GSOC][PATCH v4 0/1] microproject: use test_path_is_* functions in test scriptsVincenzo Mezzela, Mar 10, 2024
  13. [GSOC][PATCH v4 1/1] t7301: use test_path_is_(missing|file)Vincenzo Mezzela, Mar 10, 2024
  14. Junio C HamanoMar 11, 2024

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.