Re: [PATCH v2] branch.c: change install_branch_config() to use skip_prefix()
- From
Eric Sunshine <sunshine@sunshineco.com>
- Date
- Mar 2, 2014, 22:56 UTC
- Message-ID
- <CAPig+cRy2Jt_3DAS=ARzN-8HT3rdMCSGP5QfU8sJZGwqsJTG3g@mail.gmail.com>
- In-Reply-To
- <1393775755-15359-1-git-send-email-mzguanglin@gmail.com>
Thanks for the submission. Comments below to give you a taste of the Git review process...
On Sun, Mar 2, 2014 at 10:55 AM, Guanglin Xu <mzguanglin@gmail.com> wrote:
> Change install_branch_config() to use skip_prefix() and make it conform to the usage of previous starts_with(). This is because the proper usage of skip_prefix() overrides the functionality of starts_with(). Thorough replacements may finally remove the starts_with() function and reduce code redundency.
Justifying a change is certainly a good idea, however, the above reasoning for this particular change is off mark. See below.
Also, wrap commit message lines to 65-70 characters or so.
Show 15 quoted lines
> Signed-off-by: Guanglin Xu <mzguanglin@gmail.com>
> ---
> branch.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/branch.c b/branch.c
> index 723a36b..ca4e824 100644
> --- a/branch.c
> +++ b/branch.c
> @@ -50,7 +50,7 @@ static int should_setup_rebase(const char *origin)
> void install_branch_config(int flag, const char *local, const char *origin, const char *remote)
> {
> const char *shortname = remote + 11;
> - int remote_is_branch = starts_with(remote, "refs/heads/");
> + int remote_is_branch = (NULL != skip_prefix(remote ,"refs/heads/"));This actually makes the code more difficult to read and understand. There's a more fundamental reason to use skip_prefix() here. See if you can figure it out. (Hint: shortname)
Show 10 quoted lines
> struct strbuf key = STRBUF_INIT; > int rebasing = should_setup_rebase(origin); > > -- > 1.9.0 > > Hi, > I am Guanglin Xu. I plan to apply for GSoC 2014. > > This patch is in accordance with the idea#2 of GSoC2014 Microproject. Any comments are welcomed.
This sort of commentary, which is appropriate to the email discussion but not meant for permanent project history, should be placed immediately below the "---" line following your sign-off.