git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH v2] branch.c: change install_branch_config() to use skip_prefix()

From
Guanglin Xu <mzguanglin@gmail.com>
Date
Mar 3, 2014, 01:41 UTC
Message-ID
<CAATe9uhK88Gy4_EJTjJ=8ULKY0ADGrBkRArwBiVncf_2exWZEQ@mail.gmail.com>
In-Reply-To
<CAPig+cRy2Jt_3DAS=ARzN-8HT3rdMCSGP5QfU8sJZGwqsJTG3g@mail.gmail.com>
2014-03-03 6:56 GMT+08:00 Eric Sunshine <sunshine@sunshineco.com>:
Show 30 quoted lines
> Thanks for the submission. Comments below to give you a taste of the
> Git review process...
>
> On Sun, Mar 2, 2014 at 10:55 AM, Guanglin Xu <mzguanglin@gmail.com> wrote:
>> Change install_branch_config() to use skip_prefix() and make it conform to the usage of previous starts_with(). This is because the proper usage of skip_prefix() overrides the functionality of starts_with(). Thorough replacements may finally remove the starts_with() function and reduce  code redundency.
>
> Justifying a change is certainly a good idea, however, the above
> reasoning for this particular change is off mark. See below.
>
> Also, wrap commit message lines to 65-70 characters or so.
>
>> Signed-off-by: Guanglin Xu <mzguanglin@gmail.com>
>> ---
>>  branch.c | 2 +-
>>  1 file changed, 1 insertion(+), 1 deletion(-)
>>
>> diff --git a/branch.c b/branch.c
>> index 723a36b..ca4e824 100644
>> --- a/branch.c
>> +++ b/branch.c
>> @@ -50,7 +50,7 @@ static int should_setup_rebase(const char *origin)
>>  void install_branch_config(int flag, const char *local, const char *origin, const char *remote)
>>  {
>>         const char *shortname = remote + 11;
>> -       int remote_is_branch = starts_with(remote, "refs/heads/");
>> +       int remote_is_branch = (NULL != skip_prefix(remote ,"refs/heads/"));
>
> This actually makes the code more difficult to read and understand.
> There's a more fundamental reason to use skip_prefix() here. See if
> you can figure it out. (Hint: shortname)
Hi Eric,

Thanks for your hint. Now I wonder this idea is just to remove the magic code of 11.

So I would like to replace this line: const char *shortname = remote + 11; by this line: const char *shortname = skip_prefix(remote, "refs/heads/");

and keep the next line unchanged.
Am I right?
Show 15 quoted lines
>
>>         struct strbuf key = STRBUF_INIT;
>>         int rebasing = should_setup_rebase(origin);
>>
>> --
>> 1.9.0
>>
>> Hi,
>> I am Guanglin Xu. I plan to apply for GSoC 2014.
>>
>> This patch is in accordance with the idea#2 of GSoC2014 Microproject. Any comments are welcomed.
>
> This sort of commentary, which is appropriate to the email discussion
> but not meant for permanent project history, should be placed
> immediately below the "---" line following your sign-off.
Apologize for bad format. I am going to fix it by PATCH v3.
Guanglin
Previous: Eric SunshineNext: Junio C Hamano
Message 3 of 4 in “branch.c: change install_branch_config() to use skip_prefix()”
  1. branch.c: change install_branch_config() to use skip_prefix()Guanglin Xu, Mar 2, 2014
  2. Eric SunshineMar 2, 2014
  3. Guanglin XuMar 3, 2014
  4. Junio C HamanoMar 3, 2014

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.