Re: [PATCH 3/9] worktree: generalize delete_git_dir() to reduce code duplication
- From
Eric Sunshine <sunshine@sunshineco.com>
- Date
- Aug 30, 2018, 08:45 UTC
- Message-ID
- <CAPig+cR90mzorzLfQTuq73R0zx_DrAa0hThHDsghdZo=cxOWSw@mail.gmail.com>
- In-Reply-To
- <20180830065734.GA11944@sigill.intra.peff.net>
On Thu, Aug 30, 2018 at 2:57 AM Jeff King <peff@peff.net> wrote:
Show 8 quoted lines
> On Tue, Aug 28, 2018 at 05:20:20PM -0400, Eric Sunshine wrote: > > Simplify by extending delete_git_dir() to handle the little bit of > > extra functionality needed by prune_worktrees(), and drop the > > effectively duplicate code from the latter. > > Makes sense. The name "delete_git_dir()" is a little funny (I assume it > means "the git dir", not a worktree's git-dir), but that is not new (and > it's static in worktree.c, which helps).
It's not necessarily the best name, but, as you say, it's not a new issue, and it is local to that file.
Also, it's such a small function, and it's quite clear from the implementation that it's deleting stuff from .git/worktrees that it's probably okay to leave the name as-is for now.
> Your patch maybe stretches that a little by deleting non-directories. > Maybe delete_from_worktrees() would be a better name. Probably not worth > a re-roll, though.
That's perhaps a bit better, though still somewhat ambiguous, as I can also read it as deleting something from every worktree directory, as opposed to from .git/worktrees.