Re: [PATCH 3/9] worktree: generalize delete_git_dir() to reduce code duplication
- From
Jeff King <peff@peff.net>
- Date
- Aug 30, 2018, 06:57 UTC
- Message-ID
- <20180830065734.GA11944@sigill.intra.peff.net>
- In-Reply-To
- <20180828212026.21989-4-sunshine@sunshineco.com>
On Tue, Aug 28, 2018 at 05:20:20PM -0400, Eric Sunshine wrote:
Show 9 quoted lines
> prune_worktrees() and delete_git_dir() both remove worktree > administrative entries from .git/worktrees, and their implementations > are nearly identical. The only difference is that prune_worktrees() is > also capable of removing a bogus non-worktree-related file from > .git/worktrees. > > Simplify by extending delete_git_dir() to handle the little bit of > extra functionality needed by prune_worktrees(), and drop the > effectively duplicate code from the latter.
Makes sense. The name "delete_git_dir()" is a little funny (I assume it means "the git dir", not a worktree's git-dir), but that is not new (and it's static in worktree.c, which helps).
Your patch maybe stretches that a little by deleting non-directories. Maybe delete_from_worktrees() would be a better name. Probably not worth a re-roll, though.
-Peff