Re: [PATCH] ewah/bitmap: silence warning about MASK macro redefinition
- From
Eric Sunshine <sunshine@sunshineco.com>
- Date
- Jun 3, 2015, 06:28 UTC
- Message-ID
- <CAPig+cR3Xt5FNSYbDPhW=m5aEOMq8mCLRSe+mjYfVvdS0R382A@mail.gmail.com>
- In-Reply-To
- <20150603045117.GC15989@peff.net>
On Wed, Jun 3, 2015 at 12:51 AM, Jeff King <peff@peff.net> wrote:
Show 11 quoted lines
> Subject: [PATCH] ewah: use less generic macro names > > The ewah/ewok.h header pollutes the global namespace with > "BITS_IN_WORD", without any specific notion that we are > talking about the bits in an eword_t. We can give this the > more specific name "BITS_IN_EWORD". > > Likewise, ewah/bitmap.c uses the generic MASK and BLOCK > macro names. These are local to the .c file, but we have the > opposite problem: on PowerPC Mac OS X (10.5.8 "Leopard" with > Xcode 3.1), system header /usr/include/ppc/param.h[1]
The [1] has no meaning anymore, so: s/\[1\]//
Show 9 quoted lines
> pollutes the preprocessor namespace with a macro generically > named MASK. We can give these macros more specific names, as > well, to avoid this conflict. > > Reported-and-analyzed-by: Eric Sunshine <sunshine@sunshineco.com> > Signed-off-by: Jeff King <peff@peff.net> > --- > I'm also happy to split it into two patches, and make Eric the author on > the MASK part.
I don't mind being an author of a patch, so splitting works for me, however, I'm also fine with whatever you and Junio prefer. (And, in retrospect, I agree that renaming the macros here is preferable over the #undef approach.)