Re: [RFC/PATCH] worktree: replace "checkout --to" with "worktree new"
- From
Eric Sunshine <sunshine@sunshineco.com>
- Date
- Jul 1, 2015, 18:18 UTC
- Message-ID
- <CAPig+cQ7yT6mGY=hFC5gKE7GSch-_tL0u8H+haJFr3FPXjjhqw@mail.gmail.com>
- In-Reply-To
- <CAPig+cRLpJK-C7MApH1vigZS=gmHNeo6RL3S2wXv4B-TFfnq4g@mail.gmail.com>
On Wed, Jul 1, 2015 at 1:13 PM, Eric Sunshine <sunshine@sunshineco.com> wrote:
Show 14 quoted lines
> On Wed, Jul 1, 2015 at 12:53 PM, Junio C Hamano <gitster@pobox.com> wrote:
>> * Duy seems to think "worktree add" is coming, too, so here is a
>> trivial tweak of your patch from the last month, with test
>> adjustments to 7410 I sent earlier squashed in.
>
> Thanks. I was planning on re-rolling to use the new name ("add" rather
> than "new") and to squash in the t7410 fix. Plus, I think the changes
> I had to make to prepare_linked_checkout() in order to move it to
> worktree.c should become separate preparatory patches so that the
> actual relocation can become pure code movement (as much as possible).
>
> Also, I was planning on including Duy's patch in the re-roll since it
> missed a s/prune --worktrees/worktree prune/ in
> Documentation/git-checkout.txt.Hmm, I see that Duy's patch is already in 'next'. Would it be better if I fixed the 's/prune --worktrees/worktree prune/' git-checkout.txt oversight via an incremental patch rather than including a corrected version of his patch with my re-roll?