Re: [PATCH] gc: remove trailing dot from "gc.log" line
- From
Eric Sunshine <sunshine@sunshineco.com>
- Date
- Aug 31, 2021, 16:15 UTC
- Message-ID
- <CAPig+cQ1V-sSZzrBwDWZYFEFJY-W8s1aq4igfhg9vPBNdLJusA@mail.gmail.com>
- In-Reply-To
- <patch-1.1-27f00a664e6-20210831T143536Z-avarab@gmail.com>
On Tue, Aug 31, 2021 at 10:37 AM Ævar Arnfjörð Bjarmason <avarab@gmail.com> wrote:
Show 17 quoted lines
> Remove the trailing dot from the warning we emit about gc.log. It's
> common for various terminal UX's to allow the user to select "words",
> and by including the trailing dot a user wanting to select the path to
> gc.log will need to manually remove the trailing dot.
>
> Such a user would also probably need to adjust the path if it e.g. had
> spaces in it, but this should address this very common case.
>
> Signed-off-by: Ævar Arnfjörð Bjarmason <avarab@gmail.com>
> Suggested-by: Jan Judas <snugar.i@gmail.com>
> ---
> diff --git a/builtin/gc.c b/builtin/gc.c
> @@ -502,7 +502,7 @@ static int report_last_gc_error(void)
> warning(_("The last gc run reported the following. "
> "Please correct the root cause\n"
> - "and remove %s.\n"
> + "and remove %s\n"Bikeshedding: Adding a colon after "remove" would give this a slightly more grammatically-correct feel:
Please correct the root cause
and remove: /path/to/repo/.git/gc.log> "Automatic cleanup will not be performed " > "until the file is removed.\n\n" > "%s"),
Even more bikeshedding:
Please correct the root cause and remove
/path/to/repo/.git/gc.log
to allow automatic cleanup to resume.or something.