Re: [PATCH 0/9] add strip_suffix as an alternative to ends_with
On Mon, Jun 30, 2014 at 9:55 AM, Jeff King <peff@peff.net> wrote:
Show 17 quoted lines
> Here's a series to do for ends_with what the recent skip_prefix series
> did for starts_with. Namely: drop some magic numbers and repeated string
> literals, and hopefully make things more readable.
>
> The first patch is René's patch 1/2, with the leak fix from Duy and typo
> fixes in the commit message from me. The rest are new, and replace the
> changes to prepare_packed_git_one done elsewhere in the thread.
>
> [1/9]: sha1_file: replace PATH_MAX buffer with strbuf in prepare_packed_git_one()
> [2/9]: add strip_suffix function
> [3/9]: implement ends_with via strip_suffix
> [4/9]: replace has_extension with ends_with
> [5/9]: use strip_suffix instead of ends_with in simple cases
> [6/9]: index-pack: use strip_suffix to avoid magic numbers
> [7/9]: strbuf: implement strbuf_strip_suffix
> [8/9]: verify-pack: use strbuf_strip_suffix
> [9/9]: prepare_packed_git_one: refactor duplicate-pack check
Looked very sensible. Thanks all ;-)