Re: [RFC PATCH 3/5] pack-objects: add delta-islands support
- From
Christian Couder <christian.couder@gmail.com>
- Date
- Aug 5, 2018, 17:28 UTC
- Message-ID
- <CAP8UFD38--s_yCsQYu5Ou++7g15L11Bw-YcUByRxxE5yyrDjzQ@mail.gmail.com>
- In-Reply-To
- <CACsJy8CmJt1Wj=e4TNUUxY-Czn+h0BTVAWLY0ujJhgUKC+Y6yw@mail.gmail.com>
On Sun, Jul 22, 2018 at 10:55 AM, Duy Nguyen <pclouds@gmail.com> wrote:
Show 19 quoted lines
> On Sun, Jul 22, 2018 at 7:52 AM Christian Couder
> <christian.couder@gmail.com> wrote:
>>
>> - /*
>> - * And then all remaining commits and tags.
>> - */
>> - for (i = last_untagged; i < to_pack.nr_objects; i++) {
>> - if (oe_type(&objects[i]) != OBJ_COMMIT &&
>> - oe_type(&objects[i]) != OBJ_TAG)
>> - continue;
>> - add_to_write_order(wo, &wo_end, &objects[i]);
>> - }
>> + /*
>> + * Then fill all the tagged tips.
>> + */
>
> If we move the code in this loop to a separate function, in a separate
> patch, first, would it produce a better diff? I think all the
> indentation change here makes it a bit hard to read.Sorry I just realized that I forgot to try to do that. It will be on my todo list for the next iteration.
Thanks, Christian.