git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [Outreachy][PATCH] abspath: reconcile `dir_exists()` and `is_directory()`

From
Christian Couder <christian.couder@gmail.com>
Date
Oct 25, 2019, 14:47 UTC
Message-ID
<CAP8UFD1_vnjApobt+aN3M12g8mLqOZJGyvr4oqqTax5=cmLhsg@mail.gmail.com>
In-Reply-To
<xmqqzhhpb1nx.fsf@gitster-ct.c.googlers.com>
On Fri, Oct 25, 2019 at 11:43 AM Junio C Hamano <gitster@pobox.com> wrote:
Show 28 quoted lines
>
> "Miriam R." <mirucam@gmail.com> writes:
>
> > Ok, then after discussion, finally the issue tasks would be:
> >
> > - Add path_exists() that will work same as file_exists(), keeping for
> > now the latter.
> > - Use path_exists() instead of dir_exists() in builtin/clone.c.
>
> Sounds about right.
>
> > And also:
> > - Rename is_directory() to dir_exists(), as it is the equivalent to
> > path_exists()/file_exists(), isn't it?
>
> I wouldn't go there in the same series, if I were doing it.  I'd
> expect that such a patch would be more noisy than it is worth if
> done in a single step.  In order to avoid becoming a hindrance to
> other topics in flight, an ideal series to do so would support the
> same functionality with both old and new names, convert code that
> use the old name to use the new name, possibly in multiple patches
> to avoid unnecessary textual conflicts (i.e. some of these patches
> made to areas that are seeing active development will be discarded
> and need to be retried later when the area is more quiet) and then
> finally the function wither the old name gets removed.
>
> You would not want to mix the first two bullet points that are
> relatively isolated with such a long transition.

Yeah, and for a micro-project it is more than enough if you only work on the first two bullet points.

Previous: Junio C HamanoNext: Miriam R.
Message 11 of 15 in “abspath: reconcile `dir_exists()` and `is_directory()`”
  1. Miriam RubioOct 24, 2019
  2. SZEDER GáborOct 24, 2019
  3. Jeff KingOct 24, 2019
  4. Emily ShafferOct 24, 2019
  5. Jeff KingOct 24, 2019
  6. Junio C HamanoOct 25, 2019
  7. Miriam R.Oct 24, 2019
  8. Junio C HamanoOct 25, 2019
  9. Miriam R.Oct 25, 2019
  10. Junio C HamanoOct 25, 2019
  11. Christian CouderOct 25, 2019
  12. Miriam R.Oct 25, 2019
  13. Miriam R.Oct 26, 2019
  14. Christian CouderOct 26, 2019
  15. Miriam R.Oct 26, 2019

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.